Hardware cursor and console colours resetting when starting mutt

Patrick Shanahan paka at opensuse.org
Fri Sep 28 21:44:22 UTC 2018

* David Woodfall <dave at dawoodfall.net> [09-28-18 17:37]:
> Hi
> In the (framebuffer) console I've used the standard escape codes to
> set a small 1/3 block cursor to make it more visible, and softened
> the colours to not be so stark.  They were a bit of a headache
> before, and the normal cursor is very hard to see. 
> Unfortunately, when I start mutt everything resets back to the
> defaults.  I only see a couple of settings regarding the cursor, but
> they don't seem to help.  I've tried running with a -F /dev/null so
> it doesn't seem to be something in my config.  Is there any way of
> avoiding this?
> In screen it's not so bad, but the cursor resets even just switching
> to the window where mutt is running.  The colours remain as they were
> though.
> The cursor code I use is:
> printf '\e[?3c'
> Any ideas?

your chosen terminal is undoubted the cause.  I run a tmux session on my
server and attach to it remotely usually via yakuake(konsole) but have not
made any effort to change the cursor.

you have pretty well removed mutt from the equasion using "-F /dev/null".

(paka)Patrick Shanahan       Plainfield, Indiana, USA          @ptilopteri
http://en.opensuse.org    openSUSE Community Member    facebook/ptilopteri
Registered Linux User #207535                    @ http://linuxcounter.net
Photos: http://wahoo.no-ip.org/piwigo		    paka @ IRCnet freenode

More information about the Mutt-users mailing list