Mutt, NFS and errno = 31

Michelle Konzack linux4michelle at
Fri Mar 30 12:58:48 UTC 2018


Am 2018-03-30 hackte João Oliveira in die Tasten:
>   -- Minutes later I tried to save a message in this NFS-mounted Mail
>   folder and bad things happened:
>      After several seconds trying to save it mutt gave "too many
>      links, errno = 31" and I was surprised to see that the folder
>      where I tried to save the message was FILLED with copies of the
>      message to be saved, hundreds of them. I tried several times,
>      same result. Operation fails, folder is awash with copies.
>   -- I moved back Mail from NFS to local. Everything is fine.
>   -- I moved Mail from local to NFS. Too many links again.
>   -- I blamed the MH folders for it and changed everything to Maildir.
>   Same problem again: a filled folder with 1000+ copies and errno 31.
>   -- I blamed the mutt version for it (1.5.x) and compiled 1.9.y. Same
>   problem again.

mutt works perfectly with NFS, but hiw did you mount it?

I use since more then 10 years following line in my /etc/fstab: /home nfs
bg,intr,hard,tcp,vers=4,rsize=8192,wsize=8192,rw 0 0

> thanks for any help and hints,
> joao batista

Thanks in advance

Michelle Konzack        Miila ITSystems @ TDnet
GNU/Linux Developer     00372-54541400

More information about the Mutt-users mailing list