View HTML without autoview

David Woodfall dave at dawoodfall.net
Wed Mar 14 23:50:35 UTC 2018


On (14/03/18 23:23), Dave Woodfall <dave at dawoodfall.net> put forth the proposition:
>On (14/03/18 16:01), Ian Zimmerman <itz at very.loosely.org> put forth the proposition:
>>On 2018-03-14 13:13, David Woodfall wrote:
>>
>>>> Previously, I used elinks and it works fine with autoview, however
>>>> when I try to pipe to it it also renders the headers instead of just
>>>> the body.
>>
>>When you try a pipe, is that piping the message (as a pipe command would
>>do in the index view) or just the html MIME part (as a pipe command in
>>the attachment view would do)?
>
>It does the whole message. I seem to get messages where the entire
>message is html with no separate html part. Mostly from ebay.co.uk,
>even though I set to receive mail in plain text only.
>
>>>I'm still curious about how autoview works with elinks and that
>>>nametemplate though.
>>
>>The binding I have for viewing HTML is a macro which opens the
>>attachment view, searches for the html part and then calls the
>>view-mailcap command.
>>
>>-- 
>>Please don't Cc: me privately on mailing lists and Usenet,
>>if you also post the followup to the list or newsgroup.
>>To reply privately _only_ on Usenet and on broken lists
>>which rewrite From, fetch the TXT record for no-use.mooo.com.

Ha. I chatted to ebay tech support today because they
keep sending me these HTML emails even though I have set to receive
plain text. Well they must have changed something because I just had
the first mail since then and there was no body apart from:

[-- This text/html attachment (size 135K bytes) has been deleted --]
[-- on Wed, 14 Mar 2018 23:41:06 +0000 --]

No text attachment or anything else. Fun. Well at least it didn't have
any of those icons that mess up my terminal.


More information about the Mutt-users mailing list