Problem with mutt version.sh script

Paul Keusemann pkeusem at gmail.com
Mon Apr 16 12:53:56 UTC 2018


Hello,

I have just built mutt-1.9.5 on several platforms and ran into a problem 
with the version.sh script on systems where /bin/sh is not bash.

This:

{ [ -e ".git" ] && command -v git >/dev/null 2>&1; } \
|| exec cat VERSION

does not work when run in a bourne shell.  The -e option is not 
supported in the version of test built in to the bourne shell. It does 
work when run in bash or a Korn shell.

This:

{ /bin/test -e ".git" && command -v git >/dev/null 2>&1; } \
|| exec cat VERSION

does work in a bourne shell.

Thanks, Paul

-- 
Paul Keusemann			pkeusem at gmail.com
4266 Joppa Court		                     (952) 894-7805
Savage, MN  55378

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mutt.org/pipermail/mutt-dev/attachments/20180416/4392a6c1/attachment.html>


More information about the Mutt-dev mailing list